Delayed Dfinity (ICP) withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 13, 2021 - 08:57 PDT
Investigating
We are currently investigating this issue.
Posted May 11, 2021 - 17:06 PDT
This incident affected: Digital Currencies (Internet Computer).