Slow load times & degraded performance
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 4 months ago. May 05, 2017 - 09:07 PDT
Investigating
Coinbase is experiencing higher than normal traffic at this time. This may result in slow load times and degraded performance for some customers.
Posted 4 months ago. May 05, 2017 - 09:01 PDT