Issues with ID verification
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 09:32 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 26, 2020 - 09:30 PST
Monitoring
We're investigating issues with ID verifications for some customers. We'll update as we know more.
Posted Nov 24, 2020 - 11:15 PST
This incident affected: User Proofing (ID verification).