ID verification system down
Incident Report for Coinbase
Resolved
Our ID verification service has been restored to fully working order.
Posted Jun 22, 2017 - 17:38 PDT
Investigating
We are investigating possible issues with our ID verification system not functioning properly. We will update as soon as we have more information. Thank you for your patience while we investigate.
Posted Jun 22, 2017 - 16:34 PDT