Update: price alert notifications
Incident Report for Coinbase
Resolved
Mobile users may have received a number of outdated price alert notifications. We have fixed the issue and apologize for any inconvenience.
Posted Sep 17, 2017 - 21:01 PDT