Intermittent issues with document verification and email delivery
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 10 months ago. Mar 20, 2018 - 09:46 PDT
Investigating
We are currently seeing intermittent issues with document verification and email delivery. We are working to resolve the issue and hope to have all systems operating shortly.
Posted 10 months ago. Mar 20, 2018 - 09:09 PDT