Degraded performance
Incident Report for Coinbase
Resolved
This issue has been resolved & Coinbase is available for all customers.
Posted Jun 13, 2017 - 15:58 PDT
Investigating
Coinbase is currently experiencing loading issues and some customers may be unable to load www.Coinbase.com. We appreciate your patience while we work to resolve this issue.
Posted Jun 13, 2017 - 15:48 PDT