Delayed Stellar (XLM) withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 16, 2021 - 13:19 PDT
Investigating
We are currently investigating this issue.
Posted May 16, 2021 - 09:52 PDT
This incident affected: Digital Currencies (Stellar).