ID Verification Outage
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 06, 2017 - 18:02 PST
Investigating
A large percent of ID verification requests are failing to complete. Our team is aware and investigating the issue.
Posted 11 months ago. Dec 06, 2017 - 08:47 PST