Credit and debit card payment methods temporarily unavailable for planned maintenance
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 23:36 PDT
Investigating
We are beginning technical maintenance on our systems that provide credit and debit card payment methods. Please utilize other payment methods during this time.
Posted Sep 15, 2021 - 23:08 PDT
This incident affected: Payment Methods (Credit & Debit Cards).