Help Center - Support Form Outage
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 17:01 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2020 - 16:22 PDT
Investigating
We are experiencing a technical issue with our submission form and are currently unable to receive any submissions. We are working to resolve this as quickly as we can and will provide an update on the Help Center.
Posted Jun 22, 2020 - 16:01 PDT
This incident affected: Customer Support.