Google Pay payments unavailable for maintenance
Incident Report for Coinbase
Identified
Google Pay is unavailable for maintenance, please use other payment methods.
Posted Feb 04, 2022 - 16:59 PST
Investigating
We are currently investigating this issue.
Posted Feb 04, 2022 - 15:35 PST
This incident affects: Payment Methods (Google Pay).