TAO - Delayed Transactions

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted May 22, 2025 - 21:50 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2025 - 06:27 PDT

Investigating

We are aware that all users are experiencing delayed sends and receives on Bittensor Network. Buys, Sells, and Fiat withdrawals/deposits are not affected. We are investigating this issue and will provide an update shortly. Rest assured, your funds are safe.
Posted May 21, 2025 - 08:10 PDT